<!DOCTYPE html><html prefix="og: http://ogp.me/ns#" lang="en">
<head>
    <meta charset="utf-8">
    <title>Fairer Fight: Watch Corvette C8 Drag Race Stock Jeep Trackhawk</title>

    <link rel="icon" type="image/png" sizes="32x32" href="https://cdn.motor1.com/images/static/motor1/favicon-32.png">
    <link rel="icon" type="image/png" sizes="96x96" href="https://cdn.motor1.com/images/static/motor1/favicon-96.png">
    <link rel="icon" type="image/png" sizes="128x128" href="https://cdn.motor1.com/images/static/motor1/favicon-128.png">
    <link rel="icon" type="image/png" sizes="195x195" href="https://cdn.motor1.com/images/static/motor1/favicon-195.png">
    <link rel="icon" type="image/png" sizes="196x196" href="https://cdn.motor1.com/images/static/motor1/favicon-196.png">
    <link rel="icon" type="image/png" sizes="228x228" href="https://cdn.motor1.com/images/static/motor1/favicon-228.png">
    <link rel="apple-touch-icon-precomposed" href="https://cdn.motor1.com/images/static/motor1/favicon-57.png">
    <link rel="apple-touch-icon" sizes="114x114" href="https://cdn.motor1.com/images/static/motor1/favicon-114.png">
    <link rel="apple-touch-icon" sizes="72x72" href="https://cdn.motor1.com/images/static/motor1/favicon-72.png">
    <link rel="apple-touch-icon" sizes="144x144" href="https://cdn.motor1.com/images/static/motor1/favicon-144.png">
    <link rel="apple-touch-icon" sizes="60x60" href="https://cdn.motor1.com/images/static/motor1/favicon-60.png">
    <link rel="apple-touch-icon" sizes="120x120" href="https://cdn.motor1.com/images/static/motor1/favicon-120.png">
    <link rel="apple-touch-icon" sizes="76x76" href="https://cdn.motor1.com/images/static/motor1/favicon-76.png">
    <link rel="apple-touch-icon" sizes="152x152" href="https://cdn.motor1.com/images/static/motor1/favicon-152.png">
    <link rel="apple-touch-icon" sizes="180x180" href="https://cdn.motor1.com/images/static/motor1/favicon-180.png">

    <meta name="msapplication-square128x128logo" content="https://cdn.motor1.com/images/static/motor1/smalltile.png"/>
    <meta name="msapplication-square270x270logo" content="https://cdn.motor1.com/images/static/motor1/mediumtile.png"/>
    <meta name="msapplication-square580x580logo" content="https://cdn.motor1.com/images/static/motor1/largetile.png"/>

    <link rel="shortcut icon" type="image/x-icon" href="/favicon.ico"/>
            <link href="https://fonts.googleapis.com/css?family=Open+Sans:300,400,600,700" rel="stylesheet">
    
    

        <script>
        window.polymerLocale = 'en-US';
        window.polymerLocalePath = 'https://cdn.motor1.com/kp/static4ui/prod_v2_eks_148/polymer2/locales1596208659/en-US.json';
        var jsVars = {"services":{"brealtime":{"load":0,"id":"12851701"}},"ads":{"dfp":{"id":"6122441"}},"ui":{"auto_infinite_scroll":true}};    </script>

    
    <link title="Latest news" type="application/rss+xml" rel="alternate" href="/rss/news/all/"/>
    <link title="Latest videos" type="application/rss+xml" rel="alternate" href="/rss/videos/all/"/>
        <meta name="description" content="The Jeep Trackhawk is a fast SUV, and it beat the Corvette C8 back in May in a drag race.  But that one&#039;s tuned, so here&#039;s a fairer matchup.">
<meta property="og:title" content="Fairer Fight: Watch Corvette C8 Drag Race Stock Jeep Trackhawk">
<meta property="og:type" content="article">
<meta property="og:url" content="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/">
<meta property="og:image" content="https://cdn.motor1.com/images/mgl/8wLWB/s1/corvette-vs-trackhawk-drag-race-lead.jpg">
<meta property="og:image:url" content="https://cdn.motor1.com/images/mgl/8wLWB/s1/corvette-vs-trackhawk-drag-race-lead.jpg">
<meta property="og:image:secure_url" content="https://cdn.motor1.com/images/mgl/8wLWB/s1/corvette-vs-trackhawk-drag-race-lead.jpg">
<meta property="og:image:type" content="image/jpeg">
<meta property="og:image:width" content="1920">
<meta property="og:image:height" content="1080">
<meta property="og:image:alt" content="Fairer Fight: Watch Corvette C8 Drag Race Stock Jeep Trackhawk:  Chevrolet Corvette, Races and Chases">
<meta property="og:description" content="The Jeep Trackhawk is a fast SUV, and it beat the Corvette C8 back in May in a drag race.  But that one&#039;s tuned, so here&#039;s a fairer matchup.">
<meta property="og:site_name" content="Motor1.com">
<meta property="fb:admins" content="100001157785488">
<meta property="fb:app_id" content="984245018262500">
<meta property="fb:pages" content="64968240897">
<meta property="twitter:card" content="summary_large_image">
<meta property="twitter:site" content="Motor1.com">
<meta property="twitter:title" content="Fairer Fight: Watch Corvette C8 Drag Race Stock Jeep Trackhawk">
<meta property="twitter:description" content="Guess they&#039;re on the same ground now.">
<meta property="twitter:image" content="https://cdn.motor1.com/images/mgl/8wLWB/s3/corvette-vs-trackhawk-drag-race-lead.jpg">
<meta property="robots" content="max-snippet:500, max-video-preview:10, max-image-preview:large">
<meta name="speakable-description" content="The Jeep Trackhawk is a fast SUV, and it beat the Corvette C8 back in May in a drag race.  But that one&#039;s tuned, so here&#039;s a fairer matchup.">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="IE=edge"><link href="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" hreflang="x-default" rel="alternate">
<link href="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" rel="canonical">
<link href="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/amp/" rel="amphtml">    <link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_148/design/dist/css/0_6cfcdbe24482ff49b641.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_148/design/dist/css/1_6cfcdbe24482ff49b641.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_148/design/dist/css/3_6cfcdbe24482ff49b641.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_148/design/dist/css/4_6cfcdbe24482ff49b641.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_148/design/dist/css/13_6cfcdbe24482ff49b641.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_148/design/dist/css/21_6cfcdbe24482ff49b641.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_148/design/dist/css/index_articles_detail_6cfcdbe24482ff49b641.css">    
    <script>
        window.isAuthorized = 0    </script>


    

        


</head>
<body         class="nojs not-touch
            m1-fullwidth-layout            bgWhite                                                            "
        data-spotim-id="" data-edtn="us"
        data-track-url="" >

<div data-role="page" id="page_index_articles_detail" class="root">

    <div id="layout_header_spacer"></div>
<div class="m1-header-main">
    <div class="m1-header-main-box">
        <div class="m1-header-main-box-wrapper">
            <div class="box-item-left">
                <div class="m1-hamburger-button" data-hide-scroll="m1-left-side-box" data-close-delay="0.5" data-delay="0.01" onclick="" data-button data-id="toggleBox" data-value="mainMenu" data-clear="2" data-multi>
                    <span></span>
                    <span></span>
                    <span></span>
                </div>

            </div>
            <div class="wrapper-box-item-center">
                <div class="box-item-center">
                    <a class="m1-header-logo" href="/" title="Home">
                        <img class="logo_placeholder" src="data:image/png;base64,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" alt="logo">
                    </a>
                </div>
            </div>
            <div class="m1-header-main-box-wrapper-sub" style="position: relative;">
                <div class="box-item-pre-left">
                    <ul class="m1-navigation-main print-hide">
                        <li class="grand top left mobile">
            <a href="/news/"  >
                                    News                            </a>
        </li>
                    <li class="grand top left mobile">
            <a href="/reviews/"  >
                                    Reviews                            </a>
        </li>
                    <li class="grand left">
            <a href="/features/"  >
                                    Features                            </a>
        </li>
                    <li class="top left mobile">
            <a href="/shop-for-cars/"  >
                                    Shop cars                            </a>
        </li>
                    <li class="grand top">
            <a href="/makes/"  >
                                    Makes                            </a>
        </li>
                    <li class="left">
            <a href="/auto-shows/"  >
                                    Auto Shows                            </a>
        </li>
                    <li class="left">
            <a href="/news/category/spy-photos/"  >
                                    Spy Shots                            </a>
        </li>
                    <li class="left">
            <a href="/news/category/concept-car/"  >
                                    Concept Cars                            </a>
        </li>
                    <li class="left">
            <a href="/news/category/supercars/"  >
                                    Supercars                            </a>
        </li>
                    <li class="left">
            <a href="/news/?sc=1"  >
                                    All categories                            </a>
        </li>
                    <li class="left">
            <a href="/makes/"  >
                                    Makes                            </a>
        </li>
                    <li class="left">
            <a href="/body-styles/"  >
                                    Body styles                            </a>
        </li>
                    <li class="photos ico left">
            <a href="/photos/"  >
                                    Photos                            </a>
        </li>
                    <li class="videos ico left">
            <a href="/videos/"  >
                                    Videos                            </a>
        </li>
    </ul>                </div>
                                    <!-- <div class="wrapper-plugin-sale">
                        <div class="top plugin-sale">
                            <a href="https://insideevs.com/monthly-plug-in-sales-scorecard/">Ev Sales Scorecard</a>
                        </div>
                    </div> -->
                                                    <div class="m1-search-form-button-wrapper">
                        <button class="m1-search-form-button-animate icon-search"
                                onclick
                                data-button
                                data-id="toggleBox"
                                data-clear="1"
                                data-value="searchBox"
                                data-multi
                                type="submit">
                        </button>
                        <div class="m1-search-panel">
                            <form action="/search/" class="m1-search-form" method="GET" id="header_search_form" data-native="0" novalidate="novalidate">
                                <input class="m1-search-panel-input m1-search-form-text" id="search_input" type="text" value="" name="q" placeholder="Search" autocomplete="off">
                                <button class="m1-search-panel-button m1-search-form-button-animate icon-search " type="submit">
                                </button>
                                <button onclick=""
                                        data-button
                                        data-id="toggleBox"
                                        data-value="searchBox"
                                        data-clear="1"
                                        data-toggle="1"
                                        data-multi
                                        class="m1-search-panel-button m1-drawer-close-button">
                                </button>
                            </form>
                        </div>
                    </div>
                            </div>

                           <div class="box-item-right">
                    <div class="m1-editions-switcher-m" data-hide-scroll="m1-scrollbar" data-close-delay="0.5"  data-delay="0.01" onclick="" data-button data-id="toggleBox" data-value="editionsMenu" data-clear="2" data-multi>
                                                <span class="edf edf-230"></span>
                                            </div>
                    <div class="m1-editions-switcher" data-hide-scroll="m1-scrollbar" data-close-delay="0.5" data-delay="0.01" onclick="" data-button data-id="toggleBox" data-value="editionsMenu" data-clear="2" data-multi>
                                                <span class="edf edf-230"></span>
                                                <span class="title">USA / Global</span>
                    </div>
                </div>
                    </div>
    </div>
</div>
<div class="m1-header-ad top-banner-placeholder">
    <div class="m1-gapb-topside"><div class="m1-apb mleaderboard"><div class="ap" data-place="10" style="width:320px;min-height:1px;" data-dfp-code="M1/us/Mobile_Leaderboard" data-sizes="320x1,320x50,320x100" data-width="320" data-height="1" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"top-banners","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"top","m1_banner_position_view":"above-the-fold"}'></div></div><div class="m1-apb leaderboard"><div class="ap" data-place="1" style="width:728px;min-height:1px;" data-dfp-code="M1/us/Leaderboard" data-sizes="728x1,1x1,728x90" data-width="728" data-height="1" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"top-banners","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"top","m1_banner_position_view":"above-the-fold"}'></div></div><div class="m1-apb super"><div class="ap" data-place="6" style="width:970px;min-height:1px;" data-dfp-code="M1/us/Super" data-sizes="970x1,1x1,970x90,970x250,980x250" data-width="970" data-height="1" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"top-banners","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"top","m1_banner_position_view":"above-the-fold"}'></div></div></div></div>    <div class="pageAdSkin" id="page_skin_top">
        <div class="adSizer"><img alt="" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw=="></div>
        <a class="pageAdSkinUrl"></a>
    </div>
    
<script type="application/ld+json">
    {"@context":"http:\/\/schema.org","@type":"NewsArticle","headline":"Fairer Fight: Watch Corvette C8 Drag Race Stock Jeep Trackhawk","description":"The Jeep Trackhawk is a fast SUV, and it beat the Corvette C8 back in May in a drag race.  But that one's tuned, so here's a fairer matchup.","author":{"@type":"Person","name":"Jacob Oliva"},"url":"https:\/\/www.motor1.com\/news\/437448\/corvette-c8-stock-jeep-trackhawk-race\/","datePublished":"2020-08-05T02:42:37+00:00","dateModified":"2020-08-05T02:42:40+00:00","publisher":{"@type":"Organization","name":"Motor1.com","logo":{"@type":"ImageObject","url":"https:\/\/www.motor1.com\/logo.jpg","width":"325","height":"60"}},"image":{"@type":"ImageObject","url":"https:\/\/cdn.motor1.com\/images\/mgl\/8wLWB\/s1\/corvette-vs-trackhawk-drag-race-lead.jpg","width":"1920","height":"1080"},"mainEntityOfPage":{"@type":"WebPage","url":"https:\/\/www.motor1.com\/news\/437448\/corvette-c8-stock-jeep-trackhawk-race\/"},"wordCount":"319"}</script>

    <script type="application/ld+json">
        {"@context":"http:\/\/schema.org","@type":"VideoObject","contentURL":"https:\/\/www.motor1.com\/news\/437448\/corvette-c8-stock-jeep-trackhawk-race\/","name":"Fairer Fight: Watch Corvette C8 Drag Race Stock Jeep Trackhawk","description":"Guess they're on the same ground now.","uploadDate":"2020-08-05T02:42:37+00:00","thumbnailUrl":"https:\/\/cdn.motor1.com\/images\/mgl\/8wLWB\/s1\/corvette-vs-trackhawk-drag-race-lead.jpg","duration":"PT02M52S"}    </script>

    <script type="application/ld+json">
        {"@context":"https:\/\/schema.org\/","@type":"WebPage","name":"Fairer Fight: Watch Corvette C8 Drag Race Stock Jeep Trackhawk","speakable":{"@type":"SpeakableSpecification","xpath":["\/html\/head\/title","\/html\/head\/meta[@name='speakable-description']\/@content"]},"url":"https:\/\/www.motor1.com\/news\/437448\/corvette-c8-stock-jeep-trackhawk-race\/"}    </script>

        <script type="application/ld+json">
        {"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https:\/\/www.motor1.com\/"},{"@type":"ListItem","position":2,"name":"Chevrolet","item":"https:\/\/www.motor1.com\/chevrolet\/"},{"@type":"ListItem","position":3,"name":"Corvette","item":"https:\/\/www.motor1.com\/chevrolet\/corvette\/"},{"@type":"ListItem","position":4,"name":"News","item":"https:\/\/www.motor1.com\/chevrolet\/corvette\/news\/"},{"@type":"ListItem","position":5,"name":"Races and Chases","item":"https:\/\/www.motor1.com\/chevrolet\/corvette\/news\/category\/races-chases\/"}]}    </script>



    <div class="pre-center breadcrumbs-area ">
                <div slot="breadcrumbs" class="breadcrumbs">
        <a href="/">Home</a><span class="sep"></span><a href="/chevrolet/">Chevrolet</a><span class="sep"></span><a href="/chevrolet/corvette/">Corvette</a><span class="sep"></span><a href="/chevrolet/corvette/news/">News</a><span class="sep"></span><a href="/chevrolet/corvette/news/category/races-chases/">Races and Chases</a>    </div>
        <h1 class="m1-article-title">Fairer Fight: Watch Corvette C8 Drag Race Stock Jeep Trackhawk</h1>
    </div>
            <div class="kpre-center videoBoxArticle">
            <div class="videoBoxArticle-wrapper">
                
<img class="sizer" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAYAAAA7KqwyAAAAGXRFWHRTb2Z0d2FyZQBBZG9iZSBJbWFnZVJlYWR5ccllPAAAABpJREFUeNpi/P//PwMlgImBQjBqwLAwACDAAOVfAw9/ZDvcAAAAAElFTkSuQmCC" alt=""/>                <div class="video-player">
                    <iframe width="560" height="315" src="https://www.youtube.com/embed/TmcsdF2ArQ8" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>                </div>
            </div>
        </div>
    
<div class="pre-center padding h-entry  b-padding-skin pre-center-feature" id="post_box">
    <div data-bubbles="keyword" data-url="/news/store-keywords/" data-name="id"></div>
    <div class="content-area  " id="article_box" >
                    <span class="item" style="display: none;">
                <a style="display: none" href="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" class="url fn">
                    Fairer Fight: Watch Corvette C8 Drag Race Stock Jeep Trackhawk                </a>
            </span>


            <span style="display: none;" class="type">product</span>

                    <span style="display: none;" class="dt-published dtreviewed">2020-08-05 02:42:37</span>

                    <a style="display: none" rel="bookmark" href="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" class="permalink u-url">https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/</a>

                <span class="p-item item vcard" style="display: none;">
            <span class="fn">
                                                            Chevrolet Corvette                                            Jeep Grand Cherokee Trackhawk                                                </span>
        </span>

                <span class="p-category" style="display: none;">
                                                                                                                                                                    
            Races and Chases, drag race        </span>

        <div class="content-area-box">
                            <div class="postTopInfo ">
                                            <div class="postDate">
                                <span class="date" data-time="1596580957">
                    <a href="/2020/08/05/">
                Aug 04, 2020            </a>
                <span class="small">at</span> 10:42pm    </span>
                        </div>
                                        
                                            <div class="shareTrendingBox">
                                                                                                <script id="dsq-count-scr" src="//motor1dotcom.disqus.com/count.js" async></script>                                    <a title="Add a comment" href="/news/437448/corvette-c8-stock-jeep-trackhawk-race/#comments" class="disqus-comment-count" data-disqus-identifier="en-article-437448" data-disqus-url="/news/437448/corvette-c8-stock-jeep-trackhawk-race/"></a>                                                                                                                    <div slot="share-box" class="big-shareBox shareBox share-box-dropdown to-down"><div class="share-box-wrapper"><span class="shareBox-separator" data-value="share-list-1596598587" data-button onClick="" data-id="toggleBox" data-static> <span class="active"><span class="icon-plus">+</span></span><span class="passive"><span class="icon-plus">+</span></span></span><a href="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" class="share-button"><span class="name">Share</span><span class="icon share-empty"></span></a><div class="share-list" data-button-target="share-list-1596598587"><ul><li class="facebook"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'437448',type_id:'1'" data-value="1" data-share-network="Facebook" data-share-url="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-width="600" data-height="600" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.motor1.com%2Fnews%2F437448%2Fcorvette-c8-stock-jeep-trackhawk-race%2F"><span class="social-bg icon facebook"></span><span class="name">Share on Facebook</span></a></li><li class="twitter"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'437448',type_id:'1'" data-value="2" data-share-network="Twitter" data-share-url="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-width="600" data-height="450" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.motor1.com%2Fnews%2F437448%2Fcorvette-c8-stock-jeep-trackhawk-race%2F&text=Fairer+Fight%3A+Watch+Corvette+C8+Drag+Race+Stock+Jeep+Trackhawk&via=motor1com"><span class="social-bg icon twitter"></span><span class="name">Share on Twitter</span></a></li><li class="linkedin"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'437448',type_id:'1'" data-value="3" data-share-network="LinkedIn" data-share-url="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-width="600" data-height="600" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.motor1.com%2Fnews%2F437448%2Fcorvette-c8-stock-jeep-trackhawk-race%2F"><span class="social-bg icon linkedin"></span><span class="name">Share on LinkedIn</span></a></li><li class="flipboard"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'437448',type_id:'1'" data-value="7" data-share-network="Flipboard" data-share-url="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-width="600" data-height="600" href="https://share.flipboard.com/bookmarklet/popout?url=https%3A%2F%2Fwww.motor1.com%2Fnews%2F437448%2Fcorvette-c8-stock-jeep-trackhawk-race%2F&title=Fairer+Fight%3A+Watch+Corvette+C8+Drag+Race+Stock+Jeep+Trackhawk&v=2"><span class="social-bg icon flipboard"></span><span class="name">Share on Flipboard</span></a></li><li class="reddit"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'437448',type_id:'1'" data-value="6" data-share-network="Reddit" data-share-url="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-width="900" data-height="600" href="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.motor1.com%2Fnews%2F437448%2Fcorvette-c8-stock-jeep-trackhawk-race%2F"><span class="social-bg icon reddit"></span><span class="name">Share on Reddit</span></a></li><li class="whatsapp"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'437448',type_id:'1'" data-value="6" data-share-network="WhatsApp" data-share-url="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-width="600" data-height="600" href="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.motor1.com%2Fnews%2F437448%2Fcorvette-c8-stock-jeep-trackhawk-race%2F"><span class="social-bg icon whatsapp"></span><span class="name">Share on WhatsApp</span></a></li><li class="mailto"><a data-button="" data-id="mailTo" target="_blank" data-extra-params="id:'437448',type_id:'1'" data-share-url="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-width="600" data-height="400" href="mailto:?body=https%3A%2F%2Fwww.motor1.com%2Fnews%2F437448%2Fcorvette-c8-stock-jeep-trackhawk-race%2F&subject=Fairer%20Fight%3A%20Watch%20Corvette%20C8%20Drag%20Race%20Stock%20Jeep%20Trackhawk"><span class="social-bg icon mailto"></span><span class="name">Send to email</span></a></li></ul></div></div></div>                        </div>
                    
                        <div class="postAuthorBox withAvatar" xmlns="http://www.w3.org/1999/xhtml">
                    <div class="postAuthorThumb">
                <a class="userRThumb" href="/info/team/jacob-oliva/">
                    <img src="https://cdn.motor1.com/images/atr/MkGN/s4/jacob-oliva5.jpg" alt="Jacob Oliva" />
                </a>
            </div>
                <div class="postAuthorInfo">
            <div class="postAuthor">
                <span class="name">
                    <span class="label">By</span>:
                                            <a class="author h-card reviewer p-author vcard url fn" content="Jacob Oliva" href="/info/team/jacob-oliva/">Jacob Oliva</a>
                                    </span>
            </div>
                                            </div>
    </div>
                    <div class="clear"></div>

                </div>

            <div class="postContent content-wrapper">

                                    <h2 class="preview">
                        Guess they're on the same ground now.                    </h2>
                                                <div class="postBody description e-content">
                                <p>Back in May, there was a bit of outrage – a <a href="https://www.motor1.com/news/424606/jeep-trackhawk-races-corvette-escalade/" data-inline-widget="internal-links" data-type-id="0" data-params="%7B%22article_edition_id%22%3A%22424606%22%2C%22section%22%3A%221%22%2C%22alias%22%3A%22jeep-trackhawk-races-corvette-escalade%22%7D">Jeep Trackhawk beat a Chevrolet Corvette C8</a> in a <a href="https://www.motor1.com/tag/drag-race/" data-inline-widget="internal-links" data-type-id="7" data-params="%7B%22tag%22%3A%22drag%20race%22%2C%22originalTitle%22%3A%22drag%20race%22%2C%22alias%22%3A%22drag-race%22%7D">drag race</a>. It was, of course, an unfair match since the Corvette C8 there was in stock form (it was <em>Chevy Dude</em>) and the Trackhawk was upgraded up to 900 horsepower. It beat the mid-engine Corvette by almost a full second.</p><div class="apInarticleSmallRes"><div class="ap" data-place="25" style="width:300px;min-height:1px;" data-dfp-code="M1/us/Rectangle" data-sizes="300x1,300x250" data-width="300" data-height="1" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"rectangle_first","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"first-inarticle-small-res"}'></div></div>
<p>This time, let's witness a fairer matchup between the two. <a href="https://www.motor1.com/tag/hennessey/" data-inline-widget="internal-links" data-type-id="7" data-params="%7B%22tag%22%3A%22Hennessey%20Performance%22%2C%22originalTitle%22%3A%22hennessey%22%2C%22alias%22%3A%22hennessey%22%7D">Hennessey Performance</a> pitted a stock Jeep Trackhawk against a fairly stock Corvette C8 (it's equipped with a stainless steel exhaust system). Guess this puts these two cars on the same ground.</p>
    <div class="content-header" style="margin-bottom: 10px; margin-top: 30px;">
        <h3 class="mbn">Gallery: 2018 Jeep Grand Cherokee Trackhawk: First Drive</h3>
    </div>
<div itemscope itemtype="https://schema.org/ImageGallery"
         class="msnt-photo-thumb-gallery inline " >
            <meta itemprop="name" content="2018 Jeep Grand Cherokee Trackhawk: First Drive">
                <meta itemprop="thumbnailUrl" content="https://cdn.motor1.com/images/mgl/KEnVb/s3/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg">
        <div class="msnt-photo-thumb-gallery-main-photo">
            <a href="/photo/2301561/2018-jeep-grand-cherokee-trackhawk-first-drive/" class="msnt-photo-thumb-gallery-main-photo-box">
                <picture class="lazy">
                     <source data-srcset="https://cdn.motor1.com/images/mgl/KEnVb/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                         srcset="https://cdn.motor1.com/custom/share/placeholder_0.jpg">
                     <img src="https://cdn.motor1.com/custom/share/placeholder_0.jpg" alt="2018 Jeep Grand Cherokee Trackhawk: First Drive" data-src="https://cdn.motor1.com/images/mgl/KEnVb/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg" class="desaturate">                </picture>
            </a>
                        <div class="msnt-photo-thumb-gallery-count"><span class="value">30</span> <span class="label">Photos</span></div>
                    </div>
    
    <div class="msnt-photo-thumb-gallery-photos-list" data-photo-ids='2301561,2301562,2301563,2301565,2301564,2301566,2301567,2301568,2301569,2301570,2301571,2301572,2301573,2301574,2301575,2301576,2301577,2301578,2301579,2301580,2301585,2301581,2301582,2301583,2301584,2301586,2301587,2301590,2301588,2301589' data-galleryid='553717'>
                    <span
                itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
                data-url="/photo/2301561/2018-jeep-grand-cherokee-trackhawk-first-drive/"
                data-thumb="https://cdn.motor1.com/images/mgl/KEnVb/s5/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                data-caption=""
                data-src="https://cdn.motor1.com/images/mgl/KEnVb/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                data-sub-html="2018 Jeep Grand Cherokee Trackhawk: First Drive"                data-entity-id="2301561"
                data-download-url="https://cdn.motor1.com/images/mgl/KEnVb/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                                >
                                                                            <meta itemprop="name" content="2018 Jeep Grand Cherokee Trackhawk: First Drive">
                    <meta itemprop="contentUrl" content="https://cdn.motor1.com/images/mgl/KEnVb/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg">
                    <meta itemprop="width" content="1920">
                    <meta itemprop="height" content="1080">
                    <a href="/photo/2301561/2018-jeep-grand-cherokee-trackhawk-first-drive/" >
                        <picture class="lazy">
                            <source data-srcset="https://cdn.motor1.com/images/mgl/KEnVb/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                            srcset="https://cdn.motor1.com/custom/share/placeholder_1.jpg"/>
                            <img src="https://cdn.motor1.com/custom/share/placeholder_1.jpg" alt="2018 Jeep Grand Cherokee Trackhawk: First Drive" data-src="https://cdn.motor1.com/images/mgl/KEnVb/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg" class="desaturate">                        </picture>
                    </a>
                            </span>
                    <span
                itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
                data-url="/photo/2301562/2018-jeep-grand-cherokee-trackhawk-first-drive/"
                data-thumb="https://cdn.motor1.com/images/mgl/21pKp/s5/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                data-caption=""
                data-src="https://cdn.motor1.com/images/mgl/21pKp/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                data-sub-html="2018 Jeep Grand Cherokee Trackhawk: First Drive"                data-entity-id="2301562"
                data-download-url="https://cdn.motor1.com/images/mgl/21pKp/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                                >
                                                                            <meta itemprop="name" content="2018 Jeep Grand Cherokee Trackhawk: First Drive">
                    <meta itemprop="contentUrl" content="https://cdn.motor1.com/images/mgl/21pKp/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg">
                    <meta itemprop="width" content="1920">
                    <meta itemprop="height" content="1080">
                    <a href="/photo/2301562/2018-jeep-grand-cherokee-trackhawk-first-drive/" >
                        <picture class="lazy">
                            <source data-srcset="https://cdn.motor1.com/images/mgl/21pKp/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                            srcset="https://cdn.motor1.com/custom/share/placeholder_2.jpg"/>
                            <img src="https://cdn.motor1.com/custom/share/placeholder_2.jpg" alt="2018 Jeep Grand Cherokee Trackhawk: First Drive" data-src="https://cdn.motor1.com/images/mgl/21pKp/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg" class="desaturate">                        </picture>
                    </a>
                            </span>
                    <span
                itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
                data-url="/photo/2301563/2018-jeep-grand-cherokee-trackhawk-first-drive/"
                data-thumb="https://cdn.motor1.com/images/mgl/ALKq2/s5/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                data-caption=""
                data-src="https://cdn.motor1.com/images/mgl/ALKq2/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                data-sub-html="2018 Jeep Grand Cherokee Trackhawk: First Drive"                data-entity-id="2301563"
                data-download-url="https://cdn.motor1.com/images/mgl/ALKq2/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                                >
                                                                            <meta itemprop="name" content="2018 Jeep Grand Cherokee Trackhawk: First Drive">
                    <meta itemprop="contentUrl" content="https://cdn.motor1.com/images/mgl/ALKq2/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg">
                    <meta itemprop="width" content="1920">
                    <meta itemprop="height" content="1080">
                    <a href="/photo/2301563/2018-jeep-grand-cherokee-trackhawk-first-drive/" >
                        <picture class="lazy">
                            <source data-srcset="https://cdn.motor1.com/images/mgl/ALKq2/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                            srcset="https://cdn.motor1.com/custom/share/placeholder_3.jpg"/>
                            <img src="https://cdn.motor1.com/custom/share/placeholder_3.jpg" alt="2018 Jeep Grand Cherokee Trackhawk: First Drive" data-src="https://cdn.motor1.com/images/mgl/ALKq2/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg" class="desaturate">                        </picture>
                    </a>
                            </span>
                    <span
                itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
                data-url="/photo/2301565/2018-jeep-grand-cherokee-trackhawk-first-drive/"
                data-thumb="https://cdn.motor1.com/images/mgl/9x93y/s5/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                data-caption=""
                data-src="https://cdn.motor1.com/images/mgl/9x93y/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                data-sub-html="2018 Jeep Grand Cherokee Trackhawk: First Drive"                data-entity-id="2301565"
                data-download-url="https://cdn.motor1.com/images/mgl/9x93y/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                                >
                                                                            <meta itemprop="name" content="2018 Jeep Grand Cherokee Trackhawk: First Drive">
                    <meta itemprop="contentUrl" content="https://cdn.motor1.com/images/mgl/9x93y/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg">
                    <meta itemprop="width" content="1920">
                    <meta itemprop="height" content="1080">
                    <a href="/photo/2301565/2018-jeep-grand-cherokee-trackhawk-first-drive/" >
                        <picture class="lazy">
                            <source data-srcset="https://cdn.motor1.com/images/mgl/9x93y/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                            srcset="https://cdn.motor1.com/custom/share/placeholder_4.jpg"/>
                            <img src="https://cdn.motor1.com/custom/share/placeholder_4.jpg" alt="2018 Jeep Grand Cherokee Trackhawk: First Drive" data-src="https://cdn.motor1.com/images/mgl/9x93y/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg" class="desaturate">                        </picture>
                    </a>
                            </span>
                    <span
                itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
                data-url="/photo/2301564/2018-jeep-grand-cherokee-trackhawk-first-drive/"
                data-thumb="https://cdn.motor1.com/images/mgl/PjoNW/s5/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                data-caption=""
                data-src="https://cdn.motor1.com/images/mgl/PjoNW/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                data-sub-html="2018 Jeep Grand Cherokee Trackhawk: First Drive"                data-entity-id="2301564"
                data-download-url="https://cdn.motor1.com/images/mgl/PjoNW/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                                >
                                                                            <meta itemprop="name" content="2018 Jeep Grand Cherokee Trackhawk: First Drive">
                    <meta itemprop="contentUrl" content="https://cdn.motor1.com/images/mgl/PjoNW/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg">
                    <meta itemprop="width" content="1920">
                    <meta itemprop="height" content="1080">
                    <a href="/photo/2301564/2018-jeep-grand-cherokee-trackhawk-first-drive/" >
                        <picture class="lazy">
                            <source data-srcset="https://cdn.motor1.com/images/mgl/PjoNW/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                            srcset="https://cdn.motor1.com/custom/share/placeholder_5.jpg"/>
                            <img src="https://cdn.motor1.com/custom/share/placeholder_5.jpg" alt="2018 Jeep Grand Cherokee Trackhawk: First Drive" data-src="https://cdn.motor1.com/images/mgl/PjoNW/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg" class="desaturate">                        </picture>
                    </a>
                            </span>
                    <span
                itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
                data-url="/photo/2301566/2018-jeep-grand-cherokee-trackhawk-first-drive/"
                data-thumb="https://cdn.motor1.com/images/mgl/BnA4e/s5/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                data-caption=""
                data-src="https://cdn.motor1.com/images/mgl/BnA4e/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                data-sub-html="2018 Jeep Grand Cherokee Trackhawk: First Drive"                data-entity-id="2301566"
                data-download-url="https://cdn.motor1.com/images/mgl/BnA4e/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                                >
                                                                            <meta itemprop="name" content="2018 Jeep Grand Cherokee Trackhawk: First Drive">
                    <meta itemprop="contentUrl" content="https://cdn.motor1.com/images/mgl/BnA4e/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg">
                    <meta itemprop="width" content="1920">
                    <meta itemprop="height" content="1080">
                    <a href="/photo/2301566/2018-jeep-grand-cherokee-trackhawk-first-drive/" >
                        <picture class="lazy">
                            <source data-srcset="https://cdn.motor1.com/images/mgl/BnA4e/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                            srcset="https://cdn.motor1.com/custom/share/placeholder_0.jpg"/>
                            <img src="https://cdn.motor1.com/custom/share/placeholder_0.jpg" alt="2018 Jeep Grand Cherokee Trackhawk: First Drive" data-src="https://cdn.motor1.com/images/mgl/BnA4e/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg" class="desaturate">                        </picture>
                    </a>
                            </span>
                    <span
                itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
                data-url="/photo/2301567/2018-jeep-grand-cherokee-trackhawk-first-drive/"
                data-thumb="https://cdn.motor1.com/images/mgl/7Ae8o/s5/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                data-caption=""
                data-src="https://cdn.motor1.com/images/mgl/7Ae8o/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                data-sub-html="2018 Jeep Grand Cherokee Trackhawk: First Drive"                data-entity-id="2301567"
                data-download-url="https://cdn.motor1.com/images/mgl/7Ae8o/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                                >
                                                                            <meta itemprop="name" content="2018 Jeep Grand Cherokee Trackhawk: First Drive">
                    <meta itemprop="contentUrl" content="https://cdn.motor1.com/images/mgl/7Ae8o/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg">
                    <meta itemprop="width" content="1920">
                    <meta itemprop="height" content="1080">
                    <a href="/photo/2301567/2018-jeep-grand-cherokee-trackhawk-first-drive/" >
                        <picture class="lazy">
                            <source data-srcset="https://cdn.motor1.com/images/mgl/7Ae8o/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg"
                            srcset="https://cdn.motor1.com/custom/share/placeholder_1.jpg"/>
                            <img src="https://cdn.motor1.com/custom/share/placeholder_1.jpg" alt="2018 Jeep Grand Cherokee Trackhawk: First Drive" data-src="https://cdn.motor1.com/images/mgl/7Ae8o/s1/2018-jeep-grand-cherokee-trackhawk-first-drive.jpg" class="desaturate">                        </picture>
                    </a>
                            </span>
                    </div>

</div>

<p>On a side note, the souped-up <a href="https://www.motor1.com/jeep/grand-cherokee/" data-inline-widget="internal-links" data-type-id="1" data-params="%7B%22make_alias%22%3A%22jeep%22%2C%22alias%22%3A%22grand-cherokee%22%7D">Grand Cherokee</a> here was about to get an HPE1000 upgrade from Hennesey, so this was its last hurrah before some serious updates. Before you watch the video, let's compare the numbers first.</p>
<p>As we all know by now, the Corvette C8 is powered by a 6.2-liter naturally-aspirated V8 that produces 495 horsepower (361 kilowatts) and 470 pound-feet (637 Newton-meters) of torque. The C8's secret weapon is its aggressive gearing and the intelligent design of the dual-clutch transmission, which allows the mid-engine Vette to reach 60 so quickly.</p>
<section class="relatedContent-new" contenteditable="false" draggable="true" data-widget="related-content" data-widget-size="content" data-params="%7B%22type_id%22%3A0%2C%22title_id%22%3A%22%22%2C%22items%22%3A%5B%7B%22article_edition_id%22%3A%22437254%22%2C%22title%22%3A%22Order%202021%20Chevy%20Corvette%20C8%20Today%2C%20Wait%20About%2018%20Months%20To%20Drive%20It%22%2C%22alias%22%3A%222021-chevy-corvette-wait-time%22%2C%22section%22%3A%221%22%2C%22is_video%22%3A%221%22%2C%22images%22%3A%7B%22s5%22%3A%22https%3A%2F%2Fcdn.motor1.com%2Fimages%2Fmgl%2F2XmmM%2Fs5%2F2020-chevrolet-corvette-stingray.jpg%22%7D%7D%2C%7B%22article_edition_id%22%3A%22437408%22%2C%22title%22%3A%22Guy%20With%2012%2C000%20Miles%20On%20His%20Corvette%20C8%20Shares%20His%20Likes%20And%20Dislikes%22%2C%22alias%22%3A%22owner-12000-mile-corvette-report%22%2C%22section%22%3A%221%22%2C%22is_video%22%3A%220%22%2C%22images%22%3A%7B%22s5%22%3A%22https%3A%2F%2Fcdn.motor1.com%2Fimages%2Fmgl%2F9Lngm%2Fs5%2Fchevrolet-corvette-c8-12-000-mile-report.jpg%22%7D%7D%5D%7D"> <p class="trending-content_header">All About The Corvette:</p> <div class="wrapper-related-item"> <div class="related-item"><a href="https://www.motor1.com/news/437254/2021-chevy-corvette-wait-time/"> <span class="lazy related-item-img"> <span class="icon play">⠀</span> <img src="https://cdn.motor1.com/custom/share/placeholder_0.jpg" alt="2021 chevy corvette wait time" data-srcset="https://cdn.motor1.com/images/mgl/2XmmM/s6/2020-chevrolet-corvette-stingray.jpg 1x,
https://cdn.motor1.com/images/mgl/2XmmM/s4/2020-chevrolet-corvette-stingray.jpg 2x" data-src="https://cdn.motor1.com/images/mgl/2XmmM/s6/2020-chevrolet-corvette-stingray.jpg" /> </span> <span class="title-related-item">Order 2021 Chevy Corvette C8 Today, Wait About 18 Months To Drive It</span> </a></div> <div class="related-item"><a href="https://www.motor1.com/news/437408/owner-12000-mile-corvette-report/"> <span class="lazy related-item-img"> <img src="https://cdn.motor1.com/custom/share/placeholder_1.jpg" alt="owner 12000 mile corvette report" data-srcset="https://cdn.motor1.com/images/mgl/9Lngm/s6/chevrolet-corvette-c8-12-000-mile-report.jpg 1x,
https://cdn.motor1.com/images/mgl/9Lngm/s4/chevrolet-corvette-c8-12-000-mile-report.jpg 2x" data-src="https://cdn.motor1.com/images/mgl/9Lngm/s6/chevrolet-corvette-c8-12-000-mile-report.jpg" /> </span> <span class="title-related-item">Guy With 12,000 Miles On His Corvette C8 Shares His Likes And Dislikes</span> </a></div> </div> </section>
<p>On the other hand, the stock Grand Cherokee Trackhawk has a supercharged V8 that makes 707 hp (527 kW) and 645 lb-ft (875 Nm) of twists. Sure it makes a lot more than the Corvette, but keep in mind that the Chevy is also a lot lighter than the Jeep.</p><div class="item m1-ap-native"><div class="ap" data-place="22"  data-dfp-code="M1/us/Native" data-sizes="fluid,1x1" data-width="1" data-height="1" data-dfp-attrs='{"m1_native":"2","msnt_env":"production","m1_banner_place":"native","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"native"}'></div></div>
<p>With these facts laid out, which do you think won this straight-line race? The lighter Vette or the more powerful Trackhawk? The video is embedded on top, but don't hesitate to let us know what you think in the comments section below.</p><div class="apInarticleSmallRes"><div class="ap" data-place="16" style="width:300px;min-height:1px;" data-dfp-code="M1/us/Mobile_Rectangle" data-sizes="300x1,300x250,300x600" data-width="300" data-height="1" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"inarticle-small-res","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"inarticle-small-res"}'></div></div>                </div>


                                            <div class="entityInfoBlock m-top">
                                                        Source:
                            
                                                            
<span class="item"><a class="source" target="_blank" href="https://youtu.be/TmcsdF2ArQ8"> Hennessey Performance</a></span>                                                    </div>
                    
                    <!-- new gallery place -->
                    
                    
                <div class="sapb"><div class="apb mleaderboard" style="padding:15px 0 15px 0;"><div class="ap" data-place="24" style="width:290px;min-height:1px;" data-dfp-code="M1/us/Mobile_Leaderboard/Social" data-sizes="290x1,290x100" data-width="290" data-height="1" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"article_socials","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"article_socials"}'></div></div><div class="apb leaderboard" style="padding:15px 0 15px 0;"><div class="ap" data-place="23" style="width:650px;min-height:1px;" data-dfp-code="M1/us/Leaderboard/Social" data-sizes="650x1,650x100" data-width="650" data-height="1" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"article_socials","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"article_socials"}'></div></div></div>

                

                
                

                



                                


                                    <div class="parent-shareBox parent-shareBox-bottom">
                                                                                    <script id="dsq-count-scr" src="//motor1dotcom.disqus.com/count.js" async></script>                                <a title="Add a comment" href="/news/437448/corvette-c8-stock-jeep-trackhawk-race/#comments" class="disqus-comment-count" data-disqus-identifier="en-article-437448" data-disqus-url="/news/437448/corvette-c8-stock-jeep-trackhawk-race/"></a>                                                                            <div slot="share-box" class="big-shareBox shareBox share-box-dropdown to-down"><div class="share-box-wrapper"><span class="shareBox-separator" data-value="share-list-1596598357" data-button onClick="" data-id="toggleBox" data-static> <span class="active"><span class="icon-plus">+</span></span><span class="passive"><span class="icon-plus">+</span></span></span><a href="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" class="share-button"><span class="name">Share</span><span class="icon share-empty"></span></a><div class="share-list" data-button-target="share-list-1596598357"><ul><li class="facebook"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'437448',type_id:'1'" data-value="1" data-share-network="Facebook" data-share-url="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-width="600" data-height="600" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.motor1.com%2Fnews%2F437448%2Fcorvette-c8-stock-jeep-trackhawk-race%2F"><span class="social-bg icon facebook"></span><span class="name">Share on Facebook</span></a></li><li class="twitter"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'437448',type_id:'1'" data-value="2" data-share-network="Twitter" data-share-url="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-width="600" data-height="450" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.motor1.com%2Fnews%2F437448%2Fcorvette-c8-stock-jeep-trackhawk-race%2F&text=Fairer+Fight%3A+Watch+Corvette+C8+Drag+Race+Stock+Jeep+Trackhawk&via=motor1com"><span class="social-bg icon twitter"></span><span class="name">Share on Twitter</span></a></li><li class="linkedin"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'437448',type_id:'1'" data-value="3" data-share-network="LinkedIn" data-share-url="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-width="600" data-height="600" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.motor1.com%2Fnews%2F437448%2Fcorvette-c8-stock-jeep-trackhawk-race%2F"><span class="social-bg icon linkedin"></span><span class="name">Share on LinkedIn</span></a></li><li class="flipboard"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'437448',type_id:'1'" data-value="7" data-share-network="Flipboard" data-share-url="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-width="600" data-height="600" href="https://share.flipboard.com/bookmarklet/popout?url=https%3A%2F%2Fwww.motor1.com%2Fnews%2F437448%2Fcorvette-c8-stock-jeep-trackhawk-race%2F&title=Fairer+Fight%3A+Watch+Corvette+C8+Drag+Race+Stock+Jeep+Trackhawk&v=2"><span class="social-bg icon flipboard"></span><span class="name">Share on Flipboard</span></a></li><li class="reddit"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'437448',type_id:'1'" data-value="6" data-share-network="Reddit" data-share-url="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-width="900" data-height="600" href="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.motor1.com%2Fnews%2F437448%2Fcorvette-c8-stock-jeep-trackhawk-race%2F"><span class="social-bg icon reddit"></span><span class="name">Share on Reddit</span></a></li><li class="whatsapp"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'437448',type_id:'1'" data-value="6" data-share-network="WhatsApp" data-share-url="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-width="600" data-height="600" href="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.motor1.com%2Fnews%2F437448%2Fcorvette-c8-stock-jeep-trackhawk-race%2F"><span class="social-bg icon whatsapp"></span><span class="name">Share on WhatsApp</span></a></li><li class="mailto"><a data-button="" data-id="mailTo" target="_blank" data-extra-params="id:'437448',type_id:'1'" data-share-url="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-width="600" data-height="400" href="mailto:?body=https%3A%2F%2Fwww.motor1.com%2Fnews%2F437448%2Fcorvette-c8-stock-jeep-trackhawk-race%2F&subject=Fairer%20Fight%3A%20Watch%20Corvette%20C8%20Drag%20Race%20Stock%20Jeep%20Trackhawk"><span class="social-bg icon mailto"></span><span class="name">Send to email</span></a></li></ul></div></div></div>                    </div>
                
                
                
                
                

                                

                
            </div>
        </div>






                    <div class="sidebar" id="post_sidebar">
                                    <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="M1/us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"dmpu_first","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"sidebar"}'></div></div>                                            
<div class="widget-wrapper">
    <div class="rightrail">
        <img src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_148/images/logo_black_widget.png" alt="icon">
        <p>Car Buying Service</p>
        <p>Get upfront price offers on local inventory.</p>
    </div>
    <div class="radio-bar">
        <p>Search for:</p>
        <div class="radio active">
            <input id="radio-1" name="newcar" type="radio" value="1" checked>
            <label for="radio-1" class="radio-label radio-1">New Cars</label>
        </div>
        <div class="radio">
            <input id="radio-2" name="newcar" type="radio" value="0">
            <label for="radio-2" class="radio-label radio-2">Used Cars</label>
        </div>
    </div>
    <section class="choose-form only-new active-form">
        <form action="/cbs-form/" method="get" target="_blank">
            <select name="make_alias" data-url="/makes/cbs-list/" data-alias="chevrolet" class="cars_form_make make_alias_new active-select" data-ready="false" data-placeholder="Select Make"></select>
            <select name="submodel_alias" data-url="/submodels/cbs-list/" data-alias="corvette" class="cars_form_model submodel_alias_new active-select-second" data-placeholder="Select Model" ></select>
            <input name="zip" type="text" class="cars_form_zip" placeholder="Enter zip code" required>
            <input type="hidden" name="newcar" value="1" class="hidden_field"> 
            <input type="hidden" name="newcar_place" value="" class="hidden_field_place">
            <input type="submit" disabled value="Shop new cars" class="cars_form_submit active-disabled">
        </form>
    </section>
    <section class="choose-form only-used">
        <form action="/cbs-form/" method="get" target="_blank">
            <select name="make_alias" data-url="/makes/cbs-list/" class="cars_form_make make_alias_used" data-ready="false" data-placeholder="Select Make"></select>
            <select name="submodel_alias" data-url="/submodels/cbs-list/" class="cars_form_model submodel_alias_used" data-placeholder="Select Model" ></select>
            <input name="zip" type="text" class="cars_form_zip" placeholder="Enter zip code" required>
            <input type="hidden" name="newcar" value="0" class="hidden_field">
            <input type="hidden" name="newcar_place" value="" class="hidden_field_place">
            <input type="submit" disabled value="Shop used cars" class="cars_form_submit">
        </form>
    </section>
</div>                                    
                                                            <div class="trending-content">
                            <div class="content-header">
                                <p class="trending-content_header">Trending</p>
                            </div>
                                                                                                                            <div class="trending-content_item">
                                    <a class="trending-content_thumb thumb zoom"  href="/news/437092/twin-turbo-chevy-corvette-blow-engine/">
                                                                                            <span class="icon play"></span>
                                                                                    <picture class="lazy">
                                            <img src="https://cdn.motor1.com/custom/share/placeholder_2.jpg" alt="Watch Twin-Turbo 2020 Corvette Owner Go Too Far, Crack Piston In Half" data-src="https://cdn.motor1.com/images/mgl/ppNpv/s6/2020-chevy-corvette-c8-with-blown-engine-lead-image.jpg" class="desaturate">                                        </picture>
                                    </a>
                                    <a class="trending-content_link"  href="/news/437092/twin-turbo-chevy-corvette-blow-engine/">Watch Twin-Turbo 2020 Corvette Owner Go Too Far, Crack Piston In Half</a>
                                </div>
                                                                                                                            <div class="trending-content_item">
                                    <a class="trending-content_thumb thumb zoom"  href="/news/436974/ford-bronco-absolute-black-walkaround/">
                                                                                            <span class="icon play"></span>
                                                                                    <picture class="lazy">
                                            <img src="https://cdn.motor1.com/custom/share/placeholder_3.jpg" alt="First Look At 2021 Ford Bronco In Shadow Black Is Seriously Sinister" data-src="https://cdn.motor1.com/images/mgl/2Xjjk/s6/shadow-black-ford-bronco-lead.jpg" class="desaturate">                                        </picture>
                                    </a>
                                    <a class="trending-content_link"  href="/news/436974/ford-bronco-absolute-black-walkaround/">First Look At 2021 Ford Bronco In Shadow Black Is Seriously Sinister</a>
                                </div>
                                                                                                                            <div class="trending-content_item">
                                    <a class="trending-content_thumb thumb zoom"  href="/features/435323/enter-win-1967-pontiac-gto/">
                                                                                            <span class="icon play"></span>
                                                                                    <picture class="lazy">
                                            <img src="https://cdn.motor1.com/custom/share/placeholder_4.jpg" alt="Enter Now For Chance To Win The Nicest Classic Pontiac GTO We've Ever Seen" data-src="https://cdn.motor1.com/images/mgl/opgK4/s6/1967-pontiac-gto-side-angle.jpg" class="desaturate">                                        </picture>
                                    </a>
                                    <a class="trending-content_link"  href="/features/435323/enter-win-1967-pontiac-gto/">Enter Now For Chance To Win The Nicest Classic Pontiac GTO We've Ever Seen</a>
                                </div>
                                                                                                                            <div class="trending-content_item">
                                    <a class="trending-content_thumb thumb zoom"  href="/news/437243/aston-martin-dbs-gt-zagato-nurburgring/">
                                                                                    <picture class="lazy">
                                            <img src="https://cdn.motor1.com/custom/share/placeholder_5.jpg" alt="Gorgeous Aston Martin DBS GT Zagato Spied Beautifying The Nurburgring" data-src="https://cdn.motor1.com/images/mgl/A6EgV/s6/aston-dbs-zagato-spied-at-nurburgring.jpg" class="desaturate">                                        </picture>
                                    </a>
                                    <a class="trending-content_link"  href="/news/437243/aston-martin-dbs-gt-zagato-nurburgring/">Gorgeous Aston Martin DBS GT Zagato Spied Beautifying The Nurburgring</a>
                                </div>
                                                                                                                            <div class="trending-content_item">
                                    <a class="trending-content_thumb thumb zoom"  href="/news/437295/porsche-904-revival-rendering/">
                                                                                    <picture class="lazy">
                                            <img src="https://cdn.motor1.com/custom/share/placeholder_0.jpg" alt="Porsche 904 Revival Rendered As Cayman Supercar With 918 Spyder Tech" data-src="https://cdn.motor1.com/images/mgl/vkAZR/s6/porsche-904-revival-rendering.jpg" class="desaturate">                                        </picture>
                                    </a>
                                    <a class="trending-content_link"  href="/news/437295/porsche-904-revival-rendering/">Porsche 904 Revival Rendered As Cayman Supercar With 918 Spyder Tech</a>
                                </div>
                                                    </div>
                                                                        <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="M1/us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"dmpu","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"sidebar"}'></div></div>                            </div>
                <div class="clear"></div>
    </div>
</div>

                    <div class="m1-find-vehicle-mobile white-bg">
            </div>
        

<div id="container_3rd_party_service" class="container_3rd_party pre-center padding print-hide" data-edtn="us">

    <div class="content-area">
        <div class="content-area-box">
                            <div class="trending-content b-m-padding b-padding trending-content_mobile">
                    <div class="content-header">
                        <p class="trending-content_header">Trending</p>
                    </div>
                                                                    <div class="trending-content_item trending-content_item-mobile">
                            <a class="trending-content_thumb thumb zoom lazy" href="/news/437092/twin-turbo-chevy-corvette-blow-engine/" data-srcset="https://cdn.motor1.com/images/mgl/ppNpv/s6/2020-chevy-corvette-c8-with-blown-engine-lead-image.jpg" data-srcset2x="https://cdn.motor1.com/images/mgl/ppNpv/s6/2020-chevy-corvette-c8-with-blown-engine-lead-image.jpg">
                                                                    <span class="icon play"></span>
                                                                <picture class="lazy">
                                    <img src="https://cdn.motor1.com/q/images/mgl/VE1yz/s7/motor1-placeholder.jpg" data-src="https://cdn.motor1.com/images/mgl/ppNpv/s6/2020-chevy-corvette-c8-with-blown-engine-lead-image.jpg" alt="Watch Twin-Turbo 2020 Corvette Owner Go Too Far, Crack Piston In Half"/>
                                </picture>
                            </a>
                            <a class="trending-content_link" href="/news/437092/twin-turbo-chevy-corvette-blow-engine/">Watch Twin-Turbo 2020 Corvette Owner Go Too Far, Crack Piston In Half</a>
                        </div>
                                                                    <div class="trending-content_item trending-content_item-mobile">
                            <a class="trending-content_thumb thumb zoom lazy" href="/news/436974/ford-bronco-absolute-black-walkaround/" data-srcset="https://cdn.motor1.com/images/mgl/2Xjjk/s6/shadow-black-ford-bronco-lead.jpg" data-srcset2x="https://cdn.motor1.com/images/mgl/2Xjjk/s6/shadow-black-ford-bronco-lead.jpg">
                                                                    <span class="icon play"></span>
                                                                <picture class="lazy">
                                    <img src="https://cdn.motor1.com/q/images/mgl/VE1yz/s7/motor1-placeholder.jpg" data-src="https://cdn.motor1.com/images/mgl/2Xjjk/s6/shadow-black-ford-bronco-lead.jpg" alt="First Look At 2021 Ford Bronco In Shadow Black Is Seriously Sinister"/>
                                </picture>
                            </a>
                            <a class="trending-content_link" href="/news/436974/ford-bronco-absolute-black-walkaround/">First Look At 2021 Ford Bronco In Shadow Black Is Seriously Sinister</a>
                        </div>
                                                                    <div class="trending-content_item trending-content_item-mobile">
                            <a class="trending-content_thumb thumb zoom lazy" href="/features/435323/enter-win-1967-pontiac-gto/" data-srcset="https://cdn.motor1.com/images/mgl/opgK4/s6/1967-pontiac-gto-side-angle.jpg" data-srcset2x="https://cdn.motor1.com/images/mgl/opgK4/s6/1967-pontiac-gto-side-angle.jpg">
                                                                    <span class="icon play"></span>
                                                                <picture class="lazy">
                                    <img src="https://cdn.motor1.com/q/images/mgl/VE1yz/s7/motor1-placeholder.jpg" data-src="https://cdn.motor1.com/images/mgl/opgK4/s6/1967-pontiac-gto-side-angle.jpg" alt="Enter Now For Chance To Win The Nicest Classic Pontiac GTO We've Ever Seen"/>
                                </picture>
                            </a>
                            <a class="trending-content_link" href="/features/435323/enter-win-1967-pontiac-gto/">Enter Now For Chance To Win The Nicest Classic Pontiac GTO We've Ever Seen</a>
                        </div>
                                                                    <div class="trending-content_item trending-content_item-mobile">
                            <a class="trending-content_thumb thumb zoom lazy" href="/news/437243/aston-martin-dbs-gt-zagato-nurburgring/" data-srcset="https://cdn.motor1.com/images/mgl/A6EgV/s6/aston-dbs-zagato-spied-at-nurburgring.jpg" data-srcset2x="https://cdn.motor1.com/images/mgl/A6EgV/s6/aston-dbs-zagato-spied-at-nurburgring.jpg">
                                                                <picture class="lazy">
                                    <img src="https://cdn.motor1.com/q/images/mgl/VE1yz/s7/motor1-placeholder.jpg" data-src="https://cdn.motor1.com/images/mgl/A6EgV/s6/aston-dbs-zagato-spied-at-nurburgring.jpg" alt="Gorgeous Aston Martin DBS GT Zagato Spied Beautifying The Nurburgring"/>
                                </picture>
                            </a>
                            <a class="trending-content_link" href="/news/437243/aston-martin-dbs-gt-zagato-nurburgring/">Gorgeous Aston Martin DBS GT Zagato Spied Beautifying The Nurburgring</a>
                        </div>
                                                                    <div class="trending-content_item trending-content_item-mobile">
                            <a class="trending-content_thumb thumb zoom lazy" href="/news/437295/porsche-904-revival-rendering/" data-srcset="https://cdn.motor1.com/images/mgl/vkAZR/s6/porsche-904-revival-rendering.jpg" data-srcset2x="https://cdn.motor1.com/images/mgl/vkAZR/s6/porsche-904-revival-rendering.jpg">
                                                                <picture class="lazy">
                                    <img src="https://cdn.motor1.com/q/images/mgl/VE1yz/s7/motor1-placeholder.jpg" data-src="https://cdn.motor1.com/images/mgl/vkAZR/s6/porsche-904-revival-rendering.jpg" alt="Porsche 904 Revival Rendered As Cayman Supercar With 918 Spyder Tech"/>
                                </picture>
                            </a>
                            <a class="trending-content_link" href="/news/437295/porsche-904-revival-rendering/">Porsche 904 Revival Rendered As Cayman Supercar With 918 Spyder Tech</a>
                        </div>
                                    </div>
                    </div>
    </div>
    
    
    
            <div id="sponsored_content">
        </div>
    
            <div class="sellwild-container">
            <div class="sellwild-wrapper" data-src="motor1/motor1-3x3.js">
            </div>
        </div>
        <div class="content-area">
        <div class="content-area-box">
                            <div id="comments" class="comment-container no-apb">
                                                                        <div id="disqus_thread" class="diquas-wrapper" data-cid="article-437448" data-url="/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-title="Fairer Fight: Watch Corvette C8 Drag Race Stock Jeep Trackhawk">
                            </div>
                                                            </div>
                                                </div>
        <div class="sidebar">
                            <div class="mobile-adv">
                    <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="M1/us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"dmpu","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"sidebar"}'></div></div>                </div>
                <div class="lazy-load-adv">
                    <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="M1/us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"dmpu","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"sidebar"}'></div></div>                </div>
                    </div>
        <div class="clear"></div>

    </div>


    


    
                </div>

<div class="pre-center mobile-skyscraper-box">
    <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="M1/us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"dmpu","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"sidebar"}'></div></div></div>

<div class="cpre-center print-hide">
    </div>

    <div class="pre-center padding print-hide">
        <div class="content-area">
            <div class="content-area-box">
                <p class="text-uppercase bottom-heading">About this article</p>
                <table class="additionalInfo">
                                            <tr>
                            <td>Category</td>
                            <td><div class="list">
                                                                            <a href="/news/category/races-chases/">Races and Chases</a>
                                                                    </div></td>
                        </tr>
                                                                                    <tr>
                            <td>Tags</td>
                            <td>
                                <div class="list">
                                                                            <a href="/tag/drag-race/">drag race</a>
                                                                    </div>
                            </td>
                        </tr>
                                                                                                <tr>
                                <td>Make/Model</td>
                                <td>
                                    <div class="list">
                                                                                                                                <a href="/chevrolet/corvette/">Chevrolet Corvette</a>
                                                                                                                                <a href="/jeep/grand-cherokee-trackhawk/">Jeep Grand Cherokee Trackhawk</a>
                                                                            </div>
                                </td>
                            </tr>
                                                    <tr>
                                <td>Body Style</td>
                                <td>
                                    <div class="list">
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    <a href="/body-styles/coupe/">
                                                Coupe                                            </a>
                                                                                    <a href="/body-styles/suv-crossover/">
                                                SUV/Crossover                                            </a>
                                                                            </div>
                                </td>
                            </tr>
                                                            </table>
            </div>
            <div class="sidebar">

            </div>
            <div class="clear"></div>
        </div>
    </div>
    <div id="stop_share_box" class="print-hide"></div>

<div  id="ap_popup_gallery_top"><div class="apb mleaderboard"><div class="ap" data-place="10" style="width:320px;min-height:50px;" data-dfp-code="M1/us/Mobile_Leaderboard" data-sizes="320x50,320x100" data-width="320" data-height="50" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"popup_gallery_top","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"popup_gallery_top"}'></div></div><div class="apb leaderboard"><div class="ap" data-place="1" style="width:728px;min-height:90px;" data-dfp-code="M1/us/Leaderboard" data-width="728" data-height="90" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"popup_gallery_top","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"popup_gallery_top"}'></div></div><div class="apb super"><div class="ap" data-place="12" style="width:970px;min-height:90px;" data-dfp-code="M1/us/Super" data-width="970" data-height="90" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"popup_gallery_top","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"popup_gallery_top"}'></div></div></div><div id="ap_popup_gallery_rectangle"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="M1/us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"popup_gallery_rectangle","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"popup_gallery_rectangle"}'></div></div>
        </div>


<div class="m1-left-side">
    <div class="m1-drawer left-to-right disabled" data-button-target="mainMenu">
        <div onclick="" data-button data-id="toggleBox" data-close-delay="0.5" data-value="mainMenu" data-hide-scroll="m1-left-side-box" data-clear="2" class="m1-drawer-close-button dark active" data-toggle="1" data-multi></div>
        <div class="m1-left-side-top">
            <div class="m1-user-side-label">
                <span class="label flex-parent two-line">
                   <a class="login" href="/connect/msnt/">Sign In</a>
                   <span class="hide_mobile">or</span>
                   <a class="register" href="/connect/msnt/?is_registration=1">Sign Up</a>
                </span>
                <span class="hide_mobile userpic icon-user"></span>
            </div>
        </div>
        <div class="m1-left-side-box">
                        <ul class="m1-navigation-main print-hide">
                        <li class="grand top left mobile">
            <a href="/news/" >
                News            </a>
        </li>
                    <li class="grand top left mobile">
            <a href="/reviews/" >
                Reviews            </a>
        </li>
                    <li class="grand left">
            <a href="/features/" >
                Features            </a>
        </li>
                    <li class="top left mobile">
            <a href="/shop-for-cars/" >
                Shop cars            </a>
        </li>
                    <li class="grand top">
            <a href="/makes/" >
                Makes            </a>
        </li>
                    <li class="left">
            <a href="/auto-shows/" >
                Auto Shows            </a>
        </li>
                    <li class="left">
            <a href="/news/category/spy-photos/" >
                Spy Shots            </a>
        </li>
                    <li class="left">
            <a href="/news/category/concept-car/" >
                Concept Cars            </a>
        </li>
                    <li class="left">
            <a href="/news/category/supercars/" >
                Supercars            </a>
        </li>
                    <li class="left">
            <a href="/news/?sc=1" >
                All categories            </a>
        </li>
                    <li class="left">
            <a href="/makes/" >
                Makes            </a>
        </li>
                    <li class="left">
            <a href="/body-styles/" >
                Body styles            </a>
        </li>
                    <li class="photos ico left">
            <a href="/photos/" >
                Photos            </a>
        </li>
                    <li class="videos ico left">
            <a href="/videos/" >
                Videos            </a>
        </li>
    </ul>            <div class="m1-menus-box">
                <div class="m1-extra-menus-box">
                    <a href="/" class="m1-side-logo"></a>
                                        <div class="m1-editions-switcher-mobile">
                        <a href="/info/about-us/" class="m1-editions-switcher" onclick="" data-close-delay="0.5" data-delay="0.01" data-button="" data-hide-scroll="m1-scrollbar" data-id="toggleBox" data-value="editionsMenu" data-clear="2" data-multi="">
                            <span class="title">Edition:</span>
                                                        <span class="edf edf-230"></span>
                                                    </a>
                    </div>
                    
                                            <ul class="m1-social-menu">
                                                                                <li class="facebook"><a class="icon-facebook-redirect-link" href="https://www.facebook.com/motor1com" target="_blank"></a></li>
                                                                                                                                                                <li class="twitter"><a class="icon-twitter-redirect-link" href="https://twitter.com/motor1com" target="_blank"></a></li>
                                                                                                                                                                <li class="flipboard"><a class="icon-flipboard-redirect-link" href="https://flipboard.com/@Motor1com" target="_blank"></a></li>
                                                                                                            <li class="pinterest"><a class="icon-pinterest-redirect-link" href="https://www.pinterest.com/motor1com/" target="_blank"></a></li>
                                                                                                                                                                <li class="gnews"><a class="icon-gnews-redirect-link" href="https://news.google.com/publications/CAAqBwgKMPLIlAsw0ZCqAw" target="_blank"></a></li>
                                                                                                                                                                                                                                                                        <li class="instagram"><a class="icon-instagram-redirect-link" href="https://www.instagram.com/motor1com/" target="_blank"></a></li>
                                                                                                            <li class="youtube"><a class="icon-youtube-redirect-link" href="https://www.youtube.com/user/worldcarfans?sub_confirmation=1" target="_blank"></a></li>
                                                                                                                                                                                                                    <li class="rss"><a class="icon-rss-redirect-link" href="/rss/" ></a></li>
                                                                                                                                </ul>
                    
                    <ul class="m1-info-menu">
                        <li><a href="/info/about-us/">About Us</a></li>
                                                    <li><a href="https://newsletter.motor1.com/global/" target="_blank">Newsletter</a></li>
                                                <li><a href="/info/contact/">Contact</a></li>
                        <li><a href="/info/feedback/tip-us/">Tip us</a></li>
                        <li><a href="https://accounts.motorsportnetwork.com/legal/privacy-policy" target="_blank">Privacy policy</a></li>
                                                    <li>
                                <!-- OneTrust Cookies Settings button start -->
                                <button id="ot-sdk-btn" class="ot-sdk-show-settings">Cookie Settings</button>
                                <!-- OneTrust Cookies Settings button end -->
                            </li>
                                                <li><a href="/info/cookie-policy/">Cookie policy</a></li>
                        <li><a href="/info/advertising/">Advertising</a></li>
                    </ul>

                </div>
                <div class="m1-msn-menus-box">
                    <ul class="m1-msn-menu">

                        
                                                    <li class="motorsport"><a href="https://www.motorsport.com/" target="_blank">www.motorsport.com</a></li>
                                                
                        
                        
                                                    <li class="autoclassics"><a href="https://www.autoclassics.com/" target="_blank">www.autoclassics.com</a></li>
                        
                                                    <li class="rideapart"><a href="https://www.rideapart.com/" target="_blank">rideapart.com</a></li>
                            <li class="insideevs"><a href="https://insideevs.com/" target="_blank">www.insideevs.com</a></li>
                        
                        
                                                   <li class="myen"><a href="https://www.myev.com/" target="_blank">www.myev.com/</a></li>
                        
                        
                        
                        
                        
                        
                    </ul>
                </div>
                <div class="m1-footer">
                    &copy; 2020 <a target="_blank" class="m1-msn-name" href="https://www.motorsportnetwork.com/company/about">Motorsport Network.</a>                                                                 <div class="design-by">Vehicle Imagery licensed from EVOX Images</div>
                                    </div>
                            </div>
        </div>
    </div>
    <div class="m1-drawer-overlay"></div>
</div>
    
<div class="m1-right-side">
    <div class="m1-drawer right-to-left disabled" data-button-target="editionsMenu">
        
        <div onclick="" data-button data-id="toggleBox" data-value="editionsMenu" data-close-delay="0.5" data-hide-scroll="m1-scrollbar" data-clear="2" class="m1-drawer-close-button active" data-toggle="1" data-multi></div>
    
        <div class="m1-editions-switcher active" data-close-delay="0.5" data-delay="0.01" onclick="" data-button data-id="toggleBox" data-value="editionsMenu" data-clear="2" data-toggle="1" data-multi>
                        <span class="edf edf-230"></span>
                        <span class="title">USA / Global</span>
        </div>
        <div class="m1-editions-label">Our International Editions</div>
        <div class="m1-editions-box m1-scrollbar">
            
            <ul class="m1-editions-list">
                            <li class="current">

                    <a href="https://www.motor1.com">
                                        <span class="flags">
                                            <span class="edf edf-230"></span>
                                        </span>
                    <span class="label">
                                        Edition: USA / Global                    </span>
                    </a>
                </li>
                            <li>

                    <a href="https://fr.motor1.com">
                                        <span class="flags">
                                            <span class="edf edf-72"></span>
                                            <span class="edf edf-21"></span>
                                            <span class="edf edf-211"></span>
                                            <span class="edf edf-145"></span>
                                            <span class="edf edf-128"></span>
                                        </span>
                    <span class="label">
                                        Édition: France                    </span>
                    </a>
                </li>
                            <li>

                    <a href="https://it.motor1.com">
                                        <span class="flags">
                                            <span class="edf edf-106"></span>
                                        </span>
                    <span class="label">
                                        Edizione: Italia                    </span>
                    </a>
                </li>
                            <li>

                    <a href="https://de.motor1.com">
                                        <span class="flags">
                                            <span class="edf edf-80"></span>
                                            <span class="edf edf-14"></span>
                                            <span class="edf edf-211"></span>
                                        </span>
                    <span class="label">
                                        Ausgabe: Deutschland                    </span>
                    </a>
                </li>
                            <li>

                    <a href="https://ru.motor1.com">
                                        <span class="flags">
                                            <span class="edf edf-182"></span>
                                            <span class="edf edf-20"></span>
                                            <span class="edf edf-227"></span>
                                            <span class="edf edf-112"></span>
                                        </span>
                    <span class="label">
                                        Версия: Россия                    </span>
                    </a>
                </li>
                            <li>

                    <a href="https://motor1.uol.com.br">
                                        <span class="flags">
                                            <span class="edf edf-30"></span>
                                            <span class="edf edf-177"></span>
                                        </span>
                    <span class="label">
                                        Edição: Brasil                    </span>
                    </a>
                </li>
                            <li>

                    <a href="https://uk.motor1.com">
                                        <span class="flags">
                                            <span class="edf edf-229"></span>
                                            <span class="edf edf-104"></span>
                                        </span>
                    <span class="label">
                                        Edition: UK                    </span>
                    </a>
                </li>
                            <li>

                    <a href="https://tr.motor1.com">
                                        <span class="flags">
                                            <span class="edf edf-222"></span>
                                        </span>
                    <span class="label">
                                        EDİSYON: TÜRKİYE                    </span>
                    </a>
                </li>
                            <li>

                    <a href="https://es.motor1.com">
                                        <span class="flags">
                                            <span class="edf edf-132"></span>
                                        </span>
                    <span class="label">
                                        Edición: España                    </span>
                    </a>
                </li>
                            <li>

                    <a href="https://hu.motor1.com">
                                        <span class="flags">
                                            <span class="edf edf-97"></span>
                                        </span>
                    <span class="label">
                                        Edition: Magyarország                    </span>
                    </a>
                </li>
                        </ul>
            
        </div>


    
    </div>
    <div class="m1-drawer-overlay"></div>
</div>
<m1-check-availability-response-dialog
        user-data='{"email":"","zip":"","phone":"","firstName":"","lastName":""}'
        edition="us"
        oem-url="/buy/new/lead/"
        vin-url="/buy/used/lead/"
></m1-check-availability-response-dialog>


    <div id="share_box_content_wrapper">
        <div slot="share-box" class="big-shareBox shareBox share-box-dropdown to-down"><div class="share-box-wrapper"><span class="shareBox-separator" data-value="share-list-1596598609" data-button onClick="" data-id="toggleBox" data-static> <span class="active"><span class="icon-plus">+</span></span><span class="passive"><span class="icon-plus">+</span></span></span><a href="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" class="share-button"><span class="name">Share</span><span class="icon share-empty"></span></a><div class="share-list" data-button-target="share-list-1596598609"><ul><li class="facebook"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'437448',type_id:'1'" data-value="1" data-share-network="Facebook" data-share-url="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-width="600" data-height="600" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.motor1.com%2Fnews%2F437448%2Fcorvette-c8-stock-jeep-trackhawk-race%2F"><span class="social-bg icon facebook"></span><span class="name">Share on Facebook</span></a></li><li class="twitter"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'437448',type_id:'1'" data-value="2" data-share-network="Twitter" data-share-url="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-width="600" data-height="450" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.motor1.com%2Fnews%2F437448%2Fcorvette-c8-stock-jeep-trackhawk-race%2F&text=Fairer+Fight%3A+Watch+Corvette+C8+Drag+Race+Stock+Jeep+Trackhawk&via=motor1com"><span class="social-bg icon twitter"></span><span class="name">Share on Twitter</span></a></li><li class="linkedin"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'437448',type_id:'1'" data-value="3" data-share-network="LinkedIn" data-share-url="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-width="600" data-height="600" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.motor1.com%2Fnews%2F437448%2Fcorvette-c8-stock-jeep-trackhawk-race%2F"><span class="social-bg icon linkedin"></span><span class="name">Share on LinkedIn</span></a></li><li class="flipboard"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'437448',type_id:'1'" data-value="7" data-share-network="Flipboard" data-share-url="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-width="600" data-height="600" href="https://share.flipboard.com/bookmarklet/popout?url=https%3A%2F%2Fwww.motor1.com%2Fnews%2F437448%2Fcorvette-c8-stock-jeep-trackhawk-race%2F&title=Fairer+Fight%3A+Watch+Corvette+C8+Drag+Race+Stock+Jeep+Trackhawk&v=2"><span class="social-bg icon flipboard"></span><span class="name">Share on Flipboard</span></a></li><li class="reddit"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'437448',type_id:'1'" data-value="6" data-share-network="Reddit" data-share-url="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-width="900" data-height="600" href="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.motor1.com%2Fnews%2F437448%2Fcorvette-c8-stock-jeep-trackhawk-race%2F"><span class="social-bg icon reddit"></span><span class="name">Share on Reddit</span></a></li><li class="whatsapp"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'437448',type_id:'1'" data-value="6" data-share-network="WhatsApp" data-share-url="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-width="600" data-height="600" href="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.motor1.com%2Fnews%2F437448%2Fcorvette-c8-stock-jeep-trackhawk-race%2F"><span class="social-bg icon whatsapp"></span><span class="name">Share on WhatsApp</span></a></li><li class="mailto"><a data-button="" data-id="mailTo" target="_blank" data-extra-params="id:'437448',type_id:'1'" data-share-url="https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/" data-width="600" data-height="400" href="mailto:?body=https%3A%2F%2Fwww.motor1.com%2Fnews%2F437448%2Fcorvette-c8-stock-jeep-trackhawk-race%2F&subject=Fairer%20Fight%3A%20Watch%20Corvette%20C8%20Drag%20Race%20Stock%20Jeep%20Trackhawk"><span class="social-bg icon mailto"></span><span class="name">Send to email</span></a></li></ul></div></div></div>    </div>


<!--<div class="adminInfoBoxx"></div>-->
<div class="hiddenBlock">
    <div class="apOutstream"><div class="ap" data-place="8" style="width:1px;min-height:1px;" data-dfp-code="M1/us/Outstream" data-width="1" data-height="1" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"outstream","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"outstream"}'></div></div></div>
<div class="apOverlay m1-ap-overlay"><div class="ap" data-place="17" style="width:0px;min-height:0px;" data-dfp-code="M1/us/Overlay" data-width="0" data-height="0" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"overlay","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"overlay"}'></div></div><div class="apOverlay m1-ap-overlay-2"><div class="ap" data-place="18" style="width:0px;min-height:0px;" data-dfp-code="M1/us/Overlay2" data-width="0" data-height="0" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"overlay2","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"overlay2"}'></div></div><div class="apOverlay m1-ap-overlay-3"><div class="ap" data-place="20" style="width:0px;min-height:0px;" data-dfp-code="M1/us/Overlay3" data-width="0" data-height="0" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"overlay3","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"overlay3"}'></div></div><div class="apOverlay m1-ap-overlay-4"><div class="ap" data-place="21" style="width:0px;min-height:0px;" data-dfp-code="M1/us/Overlay4" data-width="0" data-height="0" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"overlay4","m1_edition":"us","m1_article_type":"news","m1_page_content_id":437448,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["chevrolet","jeep"],"m1_models":["corvette","grand-cherokee-trackhawk"],"m1_categories":["races-chases"],"m1_tags":["drag race"],"m1_body_types":["coupe","suv-crossover"],"m1_model_segments":["g","e"],"m1_banner_position":"overlay4"}'></div></div><div class="m1-footer-messages"></div>

<script>
     window.gadsId = false;
</script>
<script>
    var m1FooterMessages = [];
    m1FooterMessages.push({
        message: "This website uses cookies to ensure you get the best experience on our website. By closing this banner, scrolling this page you consent to the use of cookies. <a id='cookie_accept_link' data-id='footerMessageAccept' data-button='' href='/info/cookie-policy/'>More info.</a>",
        name: "cookie_accept"
    });
    </script>

<script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_148/design/build/jslangs/en_US_90b1785de5d9d4d318b64a471cb4dd07.js"></script>
<script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_148/design/dist/js/0_c81da40c433ac5ae8109.js"></script><script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_148/design/dist/js/2_c81da40c433ac5ae8109.js"></script><script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_148/design/dist/js/11_c81da40c433ac5ae8109.js"></script>


    
<script>
gtmDataLayer = [{
    'currentEdition': 'us',
    'currentEnv': 'production',
        'pageType': 'detail',
            'entityType': 'video',
            'make': 'Chevrolet',
            'model': 'Corvette',
            'pageId': 'index_articles_detail',
            'entityAuthors': ["Jacob Oliva"],
            'pageUrl': 'https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/',
            'pageUrlCanonical': 'https://www.motor1.com/news/437448/corvette-c8-stock-jeep-trackhawk-race/',
            'pageLanguage': 'en',
            'entityCategories': ["Races and Chases"],
            'articleType': 'news',
                    'entityTitle': 'Fairer Fight: Watch Corvette C8 Drag Race Stock Jeep Trackhawk',
            'pageTitle': 'Fairer Fight: Watch Corvette C8 Drag Race Stock Jeep Trackhawk',
            'articleId': '437448',
            'tags': ["drag race"],
                'bodyStyles': ["Coupe","SUV\/Crossover"],
        'sessionId': '361204d20550075ca291aeae08c1eadd'
}];
</script>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','gtmDataLayer','GTM-TJCLXGW');</script>

<script>
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','gtmDataLayer', 'GTM-KSXRG3K');
</script>




<!-- <script>
    window.onload = function() {

        if ((typeof $.cookie('PHPSESSID') === 'undefined') || (typeof $.cookie('is_logged_in') !== 'undefined')){
            $.get('/layout-auth-data/', function(data) {
                $('.m1-user-side-label').html(data);

                var loginButton = document.getElementsByClassName('login')[0];
                var registerButton = document.getElementsByClassName('register')[0];

                if (msnt) {
                    if (loginButton) {
                        loginButton.addEventListener('click', function(event){
                            event.preventDefault();
                            event.stopPropagation();
                            window.msnt.register = false;
                            msnt.openIframeWindow();
                        });
                    }
                    if (registerButton) {
                        registerButton.addEventListener('click', function(event){
                        event.preventDefault();
                        event.stopPropagation();
                        window.msnt.register = true;
                        msnt.openIframeWindow();
                        });
                    }
                }
            });

            var loginButton = document.getElementsByClassName('login')[0];
            var registerButton = document.getElementsByClassName('register')[0];

            if (msnt) {
                if (loginButton) {
                    loginButton.addEventListener('click', function(event){
                        event.preventDefault();
                        event.stopPropagation();
                        window.msnt.register = false;
                        msnt.openIframeWindow();
                    });
                }

                if (registerButton) {
                    registerButton.addEventListener('click', function(event){
                        event.preventDefault();
                        event.stopPropagation();
                        window.msnt.register = true;
                        msnt.openIframeWindow();
                    });
                }
            }
        }
    }

</script> -->
</body>
</html>